Announcing Support For Selenium 2.16.1, ChromeDriver 18.0.995.0 and Firefox 8 and 9

As you all know, the Selenium development team keeps moving at an incredible pace and we do our best to keep up. This time, we have the pleasure to announce that OnDemand now supports Selenium 2.16.1! Selenium 2.16.1 is the release I personally have been waiting for as it considerably improves native interactions, and fixes some pretty gnarly issues with scrolling and clicks. Here’s the changelog for more information. Along with Selenium 2.16.1, we included ChromeDriver 18.0.995.0 (changelog). We're also releasing Firefox 8 and 9 support for both Selenium 1 and Selenium 2 users. To use these browsers, you need to make sure you specify 2.16.1 as the Selenium version to use, as our current default (2.6.0) won't support them. You can start using this new version right now by adding the following Desired Capabilities/JSON key-value:

"selenium-version": "2.16.1"

During the next few weeks we'll be testing this version and depending on how it does, we'll consider moving our default version to it. If you see any issues after moving your tests to this new release, we definitely want to hear about it. For more information about the current Selenium version that is used by Sauce, how to use other Selenium versions, and the selenium-version flag, have a look at our docs in the Sauce OnDemand additional configuration section.

Written by

Santiago Suarez Ordoñez

Topics

Cross browserSelenium